eNote partner outage

Incident Report for Blend

Resolved

AT 12:58pmET EOriginal has fully restored service to eCore.
Posted Apr 18, 2025 - 17:29 UTC

Identified

There is an outage with our eNote partner, eOriginal. This is preventing the generation of eNotes. They have acknowledged the issue and are working to address.
Posted Apr 18, 2025 - 16:18 UTC
This incident affected: Lending Platform.